Login
 
Page 1 of 14 
 
 12-16-2017 01:23 PM
 Mann Incognito
 
.....and now I'm more confused than ever.

Over the past few weeks Freedom has been testing LTE in Toronto and I've been trying to get into those areas to test it out for myself. The Problem is, I'm constantly getting conflicting information from Freedom as to my phone's compatibility (Currently using BB Leap and Passport, both can operate on LTE bands 4, 7, 13(12) but new SIM only reads 2G, 3G, 4G but not LTE. Also SIM data and MMS is still set and LOCKED to WIND. Both devices were bought factory unlocked direct from BB):

a) In Answer To My Question(s) "Is My Phone Compatible?" I've received the following answers:

i) Yes;
ii) Yes but you need a new SIM card;
iii) Yes but as your device is older you'll need to wait;
iv) No.

b) In Answer To My Questions re: SIM Card Settings:

i) It's fine on its current settings, no need to change them;
ii) You'll need to change the Data and MMS Settings;
iii) We have no idea;
iv) No, SIM will default to new settings;
v) No idea why SIM won't default to new settings but you'll be fine;
vi) No idea why SIM won't default to new settings, you're screwed.

My experience in the past is that WIND/Freedom users have a far better understanding of how things work and I'm hoping that someone here can tell me if I'm wasting my time searching for LTE or not. Quite frankly, 3G+ is working well for me and I don't really need LTE but if I can hop onto that network it'll be a bonus.
 
 12-16-2017 01:40 PM
Driver8666
 
Originally posted by Mann Incognito:
.....and now I'm more confused than ever.

Over the past few weeks Freedom has been testing LTE in Toronto and I've been trying to get into those areas to test it out for myself. The Problem is, I'm constantly getting conflicting information from Freedom as to my phone's compatibility (Currently using BB Leap and Passport, both can operate on LTE bands 4, 7, 13(12) but new SIM only reads 2G, 3G, 4G but not LTE. Also SIM data and MMS is still set and LOCKED to WIND. Both devices were bought factory unlocked direct from BB):

a) In Answer To My Question(s) "Is My Phone Compatible?" I've received the following answers:

i) Yes;
ii) Yes but you need a new SIM card;
iii) Yes but as your device is older you'll need to wait;
iv) No.

b) In Answer To My Questions re: SIM Card Settings:

i) It's fine on its current settings, no need to change them;
ii) You'll need to change the Data and MMS Settings;
iii) We have no idea;
iv) No, SIM will default to new settings;
v) No idea why SIM won't default to new settings but you'll be fine;
vi) No idea why SIM won't default to new settings, you're screwed.

My experience in the past is that WIND/Freedom users have a far better understanding of how things work and I'm hoping that someone here can tell me if I'm waisting my time searching for LTE or not. Quite frankly, 3G+ is working well for me and I don't really need LTE but if I can hop onto that network


I got a P6 SIM Card the day after Freedom bought the additional spectrum, so I would not run into this problem (I cleared this with Corporate and went to a Corporate store). I hit a 4G connection on both a ZE551ML and ZE552KL, both from Asus on a P5 SIM Card(they don't tell you if it's LTE, you have to figure that one out, since the phone won't tell you it's on LTE). I would not say you are wasting your time, but I updated the "LTE in Toronto" section with what happened yesterday on my travels.

The ZE551ML is 2 years old and the ZE552KL is a year old and both of them connected to 4G. You're using a P6 SIM right? My father has a P5 SIM and is on LTE. That was the SIM used to test in the Asus Phones. There was no way I was going to remove my P6 to test from my Apple. Getting my phone out from an Otterbox Defender wasn't an option.
 
 12-16-2017 02:05 PM
 Mann Incognito
 
Originally posted by Driver8666:
I got a P6 SIM Card the day after Freedom bought the additional spectrum, so I would not run into this problem (I cleared this with Corporate and went to a Corporate store). I hit a 4G connection on both a ZE551ML and ZE552KL, both from Asus on a P5 SIM Card(they don't tell you if it's LTE, you have to figure that one out, since the phone won't tell you it's on LTE). I would not say you are wasting your time, but I updated the "LTE in Toronto" section with what happened yesterday on my travels.

The ZE551ML is 2 years old and the ZE552KL is a year old and both of them connected to 4G. You're using a P6 SIM right? My father has a P5 SIM and is on LTE. That was the SIM used to test in the Asus Phones. There was no way I was going to remove my P6 to test from my Apple. Getting my phone out from an Otterbox Defender wasn't an option.


I picked up a new SIM a couple of weeks ago which I'm assuming is the latest and greatest, how do I tell?

Amongst everything else I've been told I was informed that if I lock onto LTE it would show as 4G just because of the way my devices are set up but speed tests aren't any faster than they were previously so I'm assuming I'm not connecting.
 
 12-16-2017 02:23 PM
megamew
 
Reddit reported having same issue with BB and has nothing to do with FM but it's to do with BB having an old blackberry internet service (BIS) add-on enabled from many years ago. Give them a call to see if your BB has the old BIS add-on enabled and have them to turn it off.
 
 12-16-2017 02:33 PM
Driver8666
 
Originally posted by Mann Incognito:
I picked up a new SIM a couple of weeks ago which I'm assuming is the latest and greatest, how do I tell?

Amongst everything else I've been told I was informed that if I lock onto LTE it would show as 4G just because of the way my devices are set up but speed tests aren't any faster than they were previously so I'm assuming I'm not connecting.


Look on the SIM Card and see it P6A is stamped on it. Or look on the card you punched the SIM off of. On the bottom after freedommobile.ca

4G in this thread could mean LTE or even H+. My Dad's Samsung showed 4G when it was an H+ connection before LTE. We were actually discussing that since the 4G icon is at best misleading.
 
 12-16-2017 03:25 PM
 keefrto
 
I have had all those explanations from FM as well. I have BB KeyOne and has band 4 and 7. Don't see lte on my phone just 4g. I have three BB dtek 50, all see lte and an iPhone 6 sees it as well. All older models and I got all our Sims from corporate store. Don't understand

sent by my BB KeyOne
 
Next»
 
Share
TwitterFacebookMySpacedeliciousGoogleDiggreddit

Powered by:
WiForums
version 4.1.9F
WiForums.net


Copyright 2011, Thaddeus Clarke Jr.